WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#3452 closed defect (bug) (fixed)

xmlrpc uploads do not have attachment metadata.

Reported by: mdawaffe Owned by: mdawaffe
Milestone: 2.1 Priority: normal
Severity: normal Version: 2.1
Component: Administration Keywords: has-patch 2nd-opinion
Focuses: Cc:

Description

Files uploaded through xmlrpc don't show up all pretty like in the upload viewer.

Attached:

  1. Moves wp_create_thumbnail() to functions.php
  2. new function wp_generate_thumbnail_metadata()
  3. Uses that new function.

This has the side effect of creating thumbnails for all xmlrpc uploaded images.

Marking milestone as 2.1. Thoughts?

Attachments (1)

3452.diff (9.4 KB) - added by mdawaffe 8 years ago.

Download all attachments as: .zip

Change History (7)

@mdawaffe8 years ago

comment:1 @mdawaffe8 years ago

  • Owner changed from anonymous to mdawaffe
  • Status changed from new to assigned

comment:2 @westi8 years ago

From a quick review this looks nice.

Could we consider adding a filter to wp_create_thumbnail on the new sizes we have computed passing enough data to allow a plugin to change the sizes before we create the thumbnail?

comment:3 @mdawaffe8 years ago

#3446 - duplicate ticket (sorry) different fixes.

This patch fixes the function, the other addresses the function call.

comment:4 @Nazgul8 years ago

I think you meant #3453 is a duplicate of #3446, not this one (#3452)

comment:5 @ryan8 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [4628]) Create attachment metadata for xmlrpc uploads. Props mdawaffe. fixes #3452

comment:6 @mdawaffe8 years ago

Nazgul - yes, thanks :) I are smart.

Note: See TracTickets for help on using tickets.