WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#34622 closed defect (bug) (fixed)

Customizer wrong panel indentation

Reported by: wpfo Owned by: ocean90
Milestone: 4.6 Priority: normal
Severity: normal Version: 4.3
Component: Customize Keywords: has-patch needs-testing
Focuses: Cc:
PR Number:

Description

Panel indentation is wrong by built-in panels: Menus and Widgets
and by any user added panel.
(Error in WP Versions 4.3.1 and in current trunk 4.4-beta3-35569.)

Tested on Desktop (Host: Windows 8.1 update)
Firefox: 42.0

Change History (21)

#1 @ariwinokur
4 years ago

I attempted to replicate this issue in multiple browsers and on a Windows 10 machine running Firefox 42 with no success.

#2 @westonruter
4 years ago

  • Keywords reporter-feedback added

#3 @wpfo
4 years ago

  • Keywords needs-patch added; reporter-feedback removed

Tested on Desktop (Host: Windows 8.1 update)
Works well on:
Internet Explorer 11
Google Chrome Version 46.0.2490.80 m

#4 @wpfo
4 years ago

  • Keywords has-patch added; needs-patch removed

This should fix the problem:
This should fix also all related tickets e.g.: #34604, #33715

Last edited 4 years ago by wpfo (previous) (diff)

@wpfo
4 years ago

#5 @obenland
4 years ago

  • Version changed from trunk to 4.3

#6 @celloexpressions
3 years ago

#34604 was marked as a duplicate.

#7 @celloexpressions
3 years ago

#33715 was marked as a duplicate.

#8 @celloexpressions
3 years ago

  • Keywords needs-testing added
  • Milestone changed from Awaiting Review to Future Release

Let's consolidate #34604 and #33715 into here since this has a patch.

#9 @westonruter
3 years ago

  • Milestone changed from Future Release to 4.6

I think the issue will also be fixed with a rewrite to how panels get represented in the DOM (#34391). /cc @delawski

#10 @delawski
3 years ago

That's right, @westonruter. This issue should be fixed along with #34391.

I believe the same issue has been reported in #35947, which has a 'dirty' patch that was not included in 4.5.

#11 @monikarao
3 years ago

Just tested the patch and its working perfectly for me.
OS: Windows 10
Browser: Chrome 50.0.2661.102 , Safari 5.1.7 , IE-11 , Firefox 46.0.1
WP 4.5.2 , 4.5.3-alpha-37528
Server Environment : VVV

#12 @westonruter
3 years ago

@delawski any concerns with ticket_34622.patch?

#13 @delawski
3 years ago

@westonruter - just as @ariwinokur noted earlier, I wasn't able to reproduce the issue. However, the patch itself looks reasonable to me and is a step in right direction.

#14 @wpfo
3 years ago

The fact that I can not reproduce the error, does not mean that there is no error. There are in fact 3 tickets about the same thing.
Not sure, but I think that the half of all WordPress users can reproduce the error!
How?
One half of all Internet users, surfing the Internet on mobile phones, the other half on a 27 inch monitor with large windows font.
The tendency is that those in the first group during the time be converted into another group, and not vice versa.
This is not only cosmetic error, but it makes Customizer almost not usable.

For those that have lost patience, add the following to your theme's admin CSS file:

.accordion-sub-container.control-panel-content {
	left: 100%;
	width: 100%;
}

.in-sub-panel #customize-info,
.in-sub-panel #customize-theme-controls > ul > .accordion-section {
	left: -100%;
	width: 100%;
}

#15 @ocean90
3 years ago

  • Owner set to ocean90
  • Resolution set to fixed
  • Status changed from new to closed

In 37984:

Customize: Fix panel indentation in Firefox.

In Firefox on Windows the menus and widgets panel weren't fully visible due to a miscalculation of the width of a panel, caused by a visible scrollbar.

Props wpfo.
Fixes #34622.

Note: See TracTickets for help on using tickets.