Make WordPress Core

Opened 9 years ago

Closed 7 years ago

#34656 closed enhancement (duplicate)

the_archive_description doesn't display the custom post type description

Reported by: overclokk's profile overclokk Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.3.1
Component: Posts, Post Types Keywords: has-patch
Focuses: template Cc:

Description

A while ago a I found this bug, in CPT archive the the_archive_description function doesn't display the description arguments of the register_post_type(), it displays only description for other post type.

To replicate this bug you can create a new custom post type and add a dummy description in the $args variable and see it in archive.php and CPT's archive page.

Patch created at #wpcdit, the first Italian WordPress Contributor Day with Nikolay Bachiyski

Attachments (1)

34656.diff (2.2 KB) - added by overclokk 9 years ago.

Download all attachments as: .zip

Change History (4)

@overclokk
9 years ago

#1 @obenland
9 years ago

  • Type changed from defect (bug) to enhancement

#2 @andg
8 years ago

  • Keywords has-patch added

#3 @DrewAPicture
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a duplicate of #38487, as the patch over there provides a solution more inline with how other archive descriptions are already handled.

Note: See TracTickets for help on using tickets.