Make WordPress Core

Opened 17 years ago

Closed 17 years ago

#3466 closed defect (bug) (fixed)

RTE Link Behaviour has changed

Reported by: podz's profile podz Owned by:
Milestone: 2.1 Priority: normal
Severity: normal Version: 2.1
Component: Administration Keywords: has-patch needs-testing
Focuses: Cc:

Description

2.1a

Write the words for a link

Highlight the word

Click the chain to add the link

The word is now linked.

Click the mouse in the box to put the cursor at the end of the link.

Now click to unlink and the whole link goes. What should happen is that the </a> is applied at that point.

Attachments (1)

tiny-fixes.diff (1.0 KB) - added by andy 17 years ago.

Download all attachments as: .zip

Change History (4)

#1 @Viper007Bond
17 years ago

  • Milestone changed from 2.2 to 2.1
  • Version set to 2.1

Confirmed, but it's TinyMCE bug. Dunno if there's much we can about it. Probably best that we contact the author(s).

@andy
17 years ago

#2 @andy
17 years ago

  • Keywords has-patch needs-testing added

Attached patch to stop unlinking a link when caret is at either end of the link. This issue was caused by new code for gecko in tinymce 2.0.8. Other browsers should not be affected by the problem or the fix.

Also resolves issue where focus is not returned to editor after closing any popup. This could use testing in other browsers.

Both of these patches have been sent to tinymce dev.

#3 @ryan
17 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [4719]) RTE link behavior fix from andy. fixes #3466

Note: See TracTickets for help on using tickets.