WordPress.org

Make WordPress Core

#34673 closed defect (bug) (fixed)

Editor: link is not editable immediately after pasting a link

Reported by: designsimply Owned by:
Milestone: 4.5 Priority: normal
Severity: normal Version: 4.3.1
Component: TinyMCE Keywords:
Focuses: Cc:

Description

Steps to reproduce:

  1. Start a new post and add some text
  2. Copy any link to your clipboard
  3. Highlight the first part of a paragraph in the post and paste the link ‡
  4. Click the edit icon next to the link (the URL field is blank)
  5. Change focus off of the link, click the link again, then click the edit icon (the URL field is filled now)

Result: the URL appears blank the first time you try to edit a link after pasting a link over some text

‡ In Chrome, I only saw this problem happen if the first part of a paragraph was selected, but the problem happens for other browsers regardless of what text is selected.

Screencast: 50s
Tested with Firefox 42.0 on Mac OS X 10.10.5 using WP 4.3.1

/hat tip @akirk for the original report

Change History (2)

#1 @swissspidy
19 months ago

I can confirm this in 4.4 Beta 3 as well (using Chrome).

#2 @azaozz
14 months ago

  • Milestone changed from Awaiting Review to 4.5
  • Resolution set to fixed
  • Status changed from new to closed

This should be fixed with the inline link dialog. Re-tested in Firefox, Chrome and IE11 in 4.5-RC and all seems to be working properly. Feel free to reopen if this still happens.

Note: See TracTickets for help on using tickets.