WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 19 months ago

#34679 closed defect (bug) (fixed)

Replace use of wp_get_http() in the WordPress Importer

Reported by: danielbachhuber Owned by:
Milestone: WordPress.org Priority: lowest
Severity: minor Version:
Component: Import Keywords:
Focuses: Cc:

Description

Change History (17)

#1 @westi
4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

I don't think we need to keep this open as @rmccue has ensured it isn't used in the ongoing rewrite - https://github.com/humanmade/WordPress-Importer

#2 @danielbachhuber
4 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Given there's no specific timeline for introducing the new importer to core, can we get this fixed in a minor release of the importer?

#3 @gabrielmcgovern
4 years ago

  • Severity changed from normal to major
  • Version set to 4.4

I agree: An in-progress replacement does not mean that the bug is fixed. This heavily used tool is currently broken.

#4 @ocean90
4 years ago

  • Severity changed from major to normal

#5 @dd32
4 years ago

  • Priority changed from normal to lowest
  • Severity changed from normal to minor

This can wait until an importer refresh. Deprecated functions still operate as normal and don't require everyone to suddenly release a minor version of a plugin that removes them.

If WP-CLI displays notices by default, that's something for them to worry about.

#6 @danielbachhuber
4 years ago

In the context of WP-CLI, the problem isn't really the error notice — it's that wp_get_http() calls @set_time_limit( 60 ); internally, which means the importer can fatal while importing large files. When the importer fatals, then some amount of user data is broken.

#7 @ptasker
4 years ago

Just to follow up on this, there is an active issue on wordpress.org, people are posting their own patches :S.

https://wordpress.org/support/topic/notice-wp_get_http-is-deprecated-since-version-44?replies=12

Is there a quick fix we can get in place?

#8 @noclique
3 years ago

Need this fixed as-well.

This ticket was mentioned in Slack in #core by ocean90. View the logs.


3 years ago

This ticket was mentioned in Slack in #cli by danielbachhuber. View the logs.


3 years ago

#11 @danielbachhuber
3 years ago

@dd32 @westi This issue breaks pretty much every import I run, until I remember to hack wp_get_http() and remove the set_time_limit(). How can we get this resolved in the plugin?

#12 @ocean90
3 years ago

@danielbachhuber You could submit a PR here: https://github.com/boonebgorges/wordpress-importer

This ticket was mentioned in Slack in #core by dd32. View the logs.


3 years ago

#14 @RDall
3 years ago

I am also getting notices for:

Notice: Undefined variable: _menu_item_type in

Notice: Array to string conversion in

Using Importer in WordPress 4.7

#15 @ocean90
2 years ago

#40314 was marked as a duplicate.

This ticket was mentioned in Slack in #cli by danielbachhuber. View the logs.


2 years ago

#17 @ocean90
19 months ago

  • Keywords needs-patch removed
  • Resolution set to fixed
  • Status changed from reopened to closed
  • Version 4.4 deleted

Version 0.6.4 includes the fix for this and is now available: https://wordpress.org/plugins/wordpress-importer/

Note: See TracTickets for help on using tickets.