WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#34718 closed defect (bug) (duplicate)

User not created

Reported by: keiron77 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Users Keywords:
Focuses: Cc:
PR Number:

Description

I have found since at least v4.0.8 we are unable to save a user with a username of nz9hLKEbLJ4hpz9vMKW0p0OyoTqup3AyqT1uozSaMJ1yoaDhL29g

Adding the user returns a success message but without an edit link and they aren't added to the user db table.

Going back as far as v3.1 we are able to save this user.

Change History (4)

#1 @keiron77
4 years ago

It should be noted we have tried this on sites using an blank theme and all plugins deactivated.

#2 @MikeHansenMe
4 years ago

  • Keywords reporter-feedback added

@keiron77 is this happening with user registration open or in the admin -> add user page? I gave it a try on the current development version and was able to create the user successfully. Can you provide a bit more detail about how/where this happens for you?

#3 @keiron77
4 years ago

It was initially discovered on a front-end login using the standard ajax scripts on one of our sites. We have also tried creating the user in the admin area and again a success message appears but without the link to edit the user and no user made.

We have tried it on about 5 or 6 sites running the current version of Wordpress right back to v4.0.8 and we get the same problem. We have one really old site v3.1 where it does work. On the sites we have tried it on use a variety of plugins and themes (normally self-created) but we have a dev version of one which we were able to disable all plugins and revert the theme to a basic version with no custom functions.

These sites sit on a few different servers including Amazon and our own Apache boxes. We have looked into the database and there's no evidence of an empty record added to the users table. One one site, which I am the primary admin, I did get the email which tells me that a new account has been created but all the details were empty:

New user registration on your site XXXXXXXX:

Username:

Email:

#4 @jeremyfelt
4 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 4.0.6 deleted

It looks like this was fixed for 4.4.0 in #33793.

Note: See TracTickets for help on using tickets.