WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#34820 closed feature request (duplicate)

Expand users table user_pass field from 64 to 255 characters

Reported by: toddlahman Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Users Keywords: needs-patch
Focuses: Cc:

Description

I'd like to suggest expanding the users table user_pass field from 64 to 255 characters to allow the PHP >= 5.5 password_hash() function PASSWORD_DEFAULT option to generate a character string up to 255 characters as new and strong algorithms are added. This would allow plugins that override the default password hashing functions to not be limited to the PASSWORD_BCRYPT option going forward. Would really like to see this in WordPress 4.4.

http://php.net/manual/en/function.password-hash.php

Change History (5)

This ticket was mentioned in Slack in #core by toddlahman. View the logs.


5 years ago

#2 @johnbillion
5 years ago

  • Component changed from Database to Users
  • Keywords needs-patch added
  • Type changed from enhancement to feature request
  • Version trunk deleted

#3 @skithund
5 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #33904.

user_pass was expanded to 255 characters in [35638] and is coming in 4.4

Last edited 5 years ago by skithund (previous) (diff)

#4 @toddlahman
5 years ago

Awesome! Thanks @skithund

#5 @netweb
5 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.