WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#34824 closed defect (bug) (worksforme)

On iOS Safari the "Press This" Bookmarklet has to be pressed twice to work, it creates new tab (window), but hidden behind current window

Reported by: undergroundnetwork Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2
Component: Press This Keywords: close
Focuses: ui, javascript Cc:

Description

On iOS Safari the "Press This" Bookmarklet has to be pressed twice to work, it creates a new Safari window, but the new window remains hidden behind the current window. The user is unaware that this new window has been created.

In addition, the new hidden window is BLANK the first time the "Press This" bookmarklet is pressed, you then need to press the Bookmarklet a second time (from the main window), and then the second window gets populated properly.

To summarize: on iOS (9 and earlier) Safari

1 - "Press This" bookmarklet creates a new window when pressed once, but that window remains hidden behind the current safari window

2 - The new window is not only hidden, but is also blank. No URL is selected, it's just a new popup blank window

3 - You have to press the "Press This" bookmarklet a second time (from the original main window) to get the second window to be properly populated.

4 - Even after the second press of the bookmarklet, the new window still remains hidden behind the main Safari window. The user has no idea that anything has occurred, so the user thinks the bookmarklet is not working at all.

This issue has been happening since Press This received the major overhaul earlier this year.

Thanks!

Charles

Change History (4)

#1 @kraftbj
4 years ago

  • Focuses accessibility removed
  • Version changed from 4.3.1 to 4.2

If I recall correctly, the pop-under is something out of our control, but I may be wrong. Thanks for the report.

#2 @swissspidy
3 years ago

  • Keywords close added

I cannot seem to reproduce this, but yes, iOS opening tabs in the background is out of our control.

#3 @undergroundnetwork
3 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

It actually works correctly now.. does NOT open behind the current window. So it has been fixed.... most likely on the iOS side.

#4 @swissspidy
3 years ago

  • Milestone Awaiting Review deleted

Glad to hear that, thanks for confirming @undergroundnetwork!

Note: See TracTickets for help on using tickets.