WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#34849 closed feature request (duplicate)

Can't remove category from post while bulk editing

Reported by: Fleuv Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.3.1
Component: Quick/Bulk Edit Keywords:
Focuses: Cc:
PR Number:

Description

Consider the following bulk selected posts:

table 1

+-------+-----------+
| Name  | Category  |
+-------+-----------+
| P1    | A         |
| P2    | A         |
| P3    | B         |
+-------+-----------+

With this selection I performed 2 simple actions.

What I did first was adding category C. In this case both category A and B where not checked in the bulk edit form. The resulting after this first bulk action was the following:

table 2

+-------+-----------+
| Name  | Category  |
+-------+-----------+
| P1    | A, C      |
| P2    | A, C      |
| P3    | B, C      |
+-------+-----------+

The second bulk edit action I wanted to perform on these posts was removing category A. Again neither A, B or C was checked in the bulk edit form. So I tried to check and again uncheck the category called A. Unfortunately I got the same result as shown in table 2.

Change History (1)

#1 @SergeyBiryukov
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @Fleuv, welcome to Trac! Thanks for your report, we're already tracking this issue in #11302.

In the meantime, Batch-Move Posts plugin might be helpful.

Note: See TracTickets for help on using tickets.