WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#3490 closed defect (bug) (fixed)

Blogger Importer needs renaming

Reported by: podz Owned by:
Milestone: 2.0.6 Priority: high
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:

Description

The Import screen says "Blogger"

Blogger is now not what that importer can use. There are at least 2 versions of blogger in existence. This needs making really clear before 2.0.6

Attachments (2)

term-blogspot-retired.diff (2.9 KB) - added by foolswisdom 7 years ago.
3490-txt-old_blogger-blogspot_retired.diff (3.8 KB) - added by foolswisdom 7 years ago.
Patch updated, must forget something

Download all attachments as: .zip

Change History (11)

comment:1 markjaquith7 years ago

How can we clarify that the importer is for the old version of Blogger only? Is there established wording to differentiate the two? Maybe include a note that says it doesn't work if you use a Google login for Blogger... that's the only way I can think of to differentiate the two.

comment:2 foolswisdom7 years ago

  • Keywords has-patch added

I created term-blogspot-retired.diff a little while ago, and forgot to create a ticket. It basically addresses the problem warning that this import does not do Blogger Beta, same as how it is on WordPress.com

Once there is also a Blogger Beta importer, it will be explicitly clear.

The patch was created because Google no longer uses the term Blogspot in any of its communications particularly the Blog*Spot variety, and more importantly people will not be confused if we don't use the term either.

comment:3 foolswisdom7 years ago

  • Keywords has-patch removed

Oh, I see what Mark (Podz) is referring to. There is now two Bloggers, groan, and the beta is over.

comment:4 follow-up: shorty1147 years ago

Would there be a way to automatically differenciate between these? So if it's the old Blogger (pre-Google logins) then use that code, otherwise use the new Blogger code?

And does this have to be 2.0.6 or can it be pushed until 2.0.7? How many people use the Blogger/Blogspot importer?

comment:5 in reply to: ↑ 4 JeremyVisser7 years ago

Replying to shorty114:

Would there be a way to automatically differenciate between these? So if it's the old Blogger (pre-Google logins) then use that code, otherwise use the new Blogger code?

And does this have to be 2.0.6 or can it be pushed until 2.0.7? How many people use the Blogger/Blogspot importer?

That would be very risky for 2.0.6. We just need to mention the fact that it's currently with the "Old Blogger" (Google's terminology).

comment:6 andy7 years ago

"Old Blogger" works for me. We changed it on wordpress.com... Podz, did that help?

foolswisdom7 years ago

Patch updated, must forget something

comment:7 foolswisdom7 years ago

Mark aka Podz says "works for me"

comment:8 markjaquith7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [4679]) Change wording for Blogger import to note that it only works with OLD Blogger accounts. Props foolswisdom. fixes #3490

comment:9 markjaquith7 years ago

(In [4680]) Change wording for Blogger import to note that it only works with OLD Blogger accounts. Props foolswisdom. fixes #3490

Note: See TracTickets for help on using tickets.