WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#34901 closed enhancement (duplicate)

Update Themes in Place

Reported by: jeffr0 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8
Component: Themes Keywords: shiny-updates
Focuses: Cc:
PR Number:

Description (last modified by SergeyBiryukov)

In WordPress 4.4, when browsing the installed theme's page, I noticed that Twenty Sixteen had an update notification. I clicked on the update text thinking it would upgrade the theme but instead, it displayed a screenshot of the theme. I appreciate being notified than an update is available but it seems counter-intuitive if I have to leave the page to update the theme. If users can't update themes in place as proposed in #31531 then I question whether displaying an update notification in this location is useful at all.

Attachments (1)

WhyWontYouUpdate.png (74.8 KB) - added by jeffr0 4 years ago.
Update Notification on Installed Themes

Download all attachments as: .zip

Change History (6)

@jeffr0
4 years ago

Update Notification on Installed Themes

#1 follow-up: @obenland
4 years ago

  • Keywords shiny-updates added
  • Version changed from 4.4 to 3.8

Did you click on "Update Available" in your screenshot or "update now" in the single theme view?

#2 in reply to: ↑ 1 ; follow-up: @jeffr0
4 years ago

Replying to obenland:

Did you click on "Update Available" in your screenshot or "update now" in the single theme view?

I clicked the Update Available text. I then tried to click the update icon. Both result is seeing a screenshot of the theme and not updating inline.

Ahh, I see now that once I click the theme details, there is text and a link to update the theme immediately even though this flow removes me from the themes page.

#3 in reply to: ↑ 2 @obenland
4 years ago

Replying to jeffr0:

I clicked the Update Available text. I then tried to click the update icon. Both result is seeing a screenshot of the theme and not updating inline.

Hmm, that sounds suspicious. Is this on a vanilla install? Has the screen fully loaded when you click the text? Clicking anywhere in the theme card should open the overlay.

#4 @obenland
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #31529.

#5 @SergeyBiryukov
4 years ago

  • Description modified (diff)
Note: See TracTickets for help on using tickets.