WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#34922 closed enhancement (duplicate)

Focus on nav menu item control when shift+clicking (or long-press?) on a menu item in preview

Reported by: westonruter Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.3
Component: Customize Keywords: needs-patch
Focuses: javascript Cc:

Description

When widgets were added to the Customizer in 3.9, there was a somewhat hidden feature whereby a user can shift+click on a widget in the preview and the corresponding control would be focused in the pane (along with expanding the panel and section). There are also highlight outlines around each widget in the preview when interacting with a widget control, and likewise when hovering over a widget in the preview the corresponding control gets an outline in the pane. These features lessen the disconnect between the controls in the pane and the elements in the preview, and they serve as a stopgap for eventual inline controls that float next to the element being modified. For more on improving the discoverability of this shift+click mechanism, see #27403.

Nav menu items would benefit a lot from having the same functionality. Shift+clicking on a nav menu item could focus on the corresponding control in the Customizer pane. This would make it _much_ faster to edit the desired menu item, since the user wouldn't have to open the menus panel, and then figure out which menu section contains the nav menu item, to then expand and then locate the nav menu item in the list.

For discussion on whether shift+click is even a desirable way to activate this feature, see: https://wordpress.slack.com/archives/core-customize/p1449592641000150

Change History (3)

This ticket was mentioned in Slack in #core-customize by westonruter. View the logs.


2 years ago

#3 @westonruter
2 years ago

  • Milestone 4.5 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #32681.

@paulwilde :facepalm: I thought I had seen something reported previously, but I couldn't find it. Thanks :)

Note: See TracTickets for help on using tickets.