Make WordPress Core

Opened 9 years ago

Closed 8 years ago

#34952 closed defect (bug) (invalid)

srcset responsive images conflicting with bxslider on genesis framework (Firefox Specific)

Reported by: brightervision's profile brightervision Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4
Component: Media Keywords: close
Focuses: Cc:

Description

Our company has multiple sites utilizing Wordpress with an installation Bootstrap Genesis frame work.

When viewing the slider specifically on Firefox, there are appears to be a conflict with the responsiveness, we believe which is attributed to the new srcset responsive image classes in Wordpress 4.4.

Upon loading a site, for example http://brightervisiontheme.com/ only about 50 pixels of the slider image appear. Upon resizing the browser, the issue is resolved and the slider regains its normal responsive qualities and height.

Testing sites that were not updated to 4.4, the issue does not appear, so we are assuming it is Bug in relation to the new installation.

Change History (8)

#1 @azaozz
9 years ago

Confirmed, works properly in Chrome and IE11 but not in Firefox. Seems caused by the slider js. In Firefox it sets the height for the slider wrap to 26px, then corrects it to 400px on window resize.

I'd suggest reporting this bug to the author of that js and asking for a fix.

#2 @brightervision
9 years ago

Thank you for such a quick reply.

Could you please clarify which specific js file it is?

This works (worked) fine prior to the new WordPress update. Is this something that might be patched and fixed in the next WordPress release?

Thank you

This ticket was mentioned in Slack in #feature-respimg by jaspermdegroot. View the logs.


9 years ago

#4 @jaspermdegroot
9 years ago

@brightervision

There was a bug in Firefox which might be the cause of the problem that you see. The Picturefill polyfill (http://scottjehl.github.io/picturefill/) contains a fix for that and it should be fixed in Firefox 42.
To easily test if that fixes the issue you could install the RICG Responsive Images plugin (https://wordpress.org/plugins/ricg-responsive-images/). When you are on WordPress 4.4 the plugin will only add Picturefill to your site, nothing else.

#5 @joemcgill
9 years ago

I believe FF ended up not fixing the bug until version 45. Here's the ticket on bugzilla and the related update to Picturefill.

#6 @SergeyBiryukov
9 years ago

  • Component changed from General to Media

#7 follow-up: @dd32
8 years ago

  • Keywords close added

If I'm reading this correctly, it sounds like a browser bug that core can't really work around?

#8 in reply to: ↑ 7 @azaozz
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Replying to dd32:

Right. It may be possible to be fixed from the slider JS until it gets resolved in Firefox. There's nothing we can do.

Closing as invalid. Has to be fixed in the browser, temp fix can be implemented by the JS library.

Note: See TracTickets for help on using tickets.