WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#34961 closed defect (bug) (invalid)

'View Page' Button / link missing in the single post edit screen

Reported by: simonrcodrington Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4
Component: Posts, Post Types Keywords:
Focuses: Cc:

Description

Hey there guys,

I've noticed in several of my sites that I've updated to WordPress 4.4 that the 'View Page' / 'View {content type}' button is missing.

Previously the view button was next to the edit / shortlink buttons as seen below

https://goo.gl/FOP7AC

After 4.4 the button is now gone.

https://goo.gl/L072i8

The 'View' button still exists inside the top navigation menu, but my expectation is that as soon as I enter a post for editing I can immediately view it. Right now there is just an edit for the permalink button and that it is.

When saving, there is a success admin notice that appears above it which can be used, but I don't see why it's necessary to remove a button that worked perfectly fine.

Is this a bug? if not is there a thread or chain where it was outlined this would be removed in 4.4 as I need to follow up with my clients now as they keep asking me where the view button has gone.

Cheers!

Simon

Change History (4)

#1 @SergeyBiryukov
5 years ago

  • Component changed from Administration to Posts, Post Types

Is this a bug? if not is there a thread or chain where it was outlined this would be removed in 4.4 as I need to follow up with my clients now as they keep asking me where the view button has gone.

Not a bug, see #18306.

#2 @atomicjack
5 years ago

  • Resolution set to invalid
  • Status changed from new to closed

This was removed as it was redundant - there were too many buttons littered around the screens to View a post/page.

#3 @simonrcodrington
5 years ago

Thanks for the reply guys. I'll follow up my comments on that other thread. I'm still not a fan of removing the button itself as I doubt many basic editors will understand what the 'permalink' actually is.

#4 @swissspidy
5 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.