WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#35005 closed defect (bug) (invalid)

updating to 4.4 causes 500 internal server error

Reported by: ian.edington Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4
Component: General Keywords:
Focuses: Cc:

Description

Upgrading to 4.4 from 4.31 causes this error:

PHP Fatal error:  Call to undefined function is_embed() in ~/public_staging/wp/wp-includes/template-loader.php on line 42

This is line 42

<?php
elseif ( is_embed() ) :

Change History (5)

#1 @ian.edington
5 years ago

  • Summary changed from is_embed to updating to 4.4 causes 500 internal server error

#2 @SergeyBiryukov
5 years ago

  • Keywords close reporter-feedback added

Hi @ian.edington, welcome to Trac!

This sounds like an incomplete update. The function is defined in wp-includes/query.php.

Could you try a manual update? Please try the support forums if you need more help.

#3 @dd32
5 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

This is most definitely caused by a partial update.

#4 @ian.edington
5 years ago

  • Keywords reporter-feedback removed

#5 @MarcGuay
5 years ago

I had this problem when refreshing an internal admin page after updating. What solved it was returning to the wp-login.php screen and reauthenticating, I was then taken through the update process properly. Possibly something to do with caching?

Note: See TracTickets for help on using tickets.