WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#35011 closed defect (bug) (worksforme)

Some comments appear under wrong article

Reported by: Atari-Frosch Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Comments Keywords: reporter-feedback close
Focuses: Cc:

Description

I'm watching this since some time, so it is not (only) related to the current version 4.4.x; but I cannot tell when and with which version I saw the problem the first time.

Sometimes (not very often) a comment appears under a different article it was written for. It appeared to comments made directly to the article, but also to comments which were written as answers to other comments.

I have seen that several times, but these were always comments written by visitors. So I could never be sure whether the commentor had made a mistake or it was a bug in WordPress.

Today it happened to one of my own comments. I answered to a certain user's comment under my latest article, and it appeared as an answer to another comment written by the same user under a different article (written around two weeks earlier than my currently latest).

Because it was my own I then made a local copy and delete the wrong placed comment. Then I replied again and this time it was placed under the correct article.

Reproducing seems difficult, and I don't get so many comments that I could extract a pattern. Not earlier than January I might find the time to play around with a local test installation, but I cannot make a promise on this.

Change History (3)

#1 @swissspidy
5 years ago

  • Keywords reporter-feedback added
  • Version 4.4 deleted

Hi there

When you look at the database entry, does the comment really have a wrong post ID / comment ID attached? This might indicate where this bug happens.

Also, does this still happen with all plugins disabled and when using one of the bundled default themes?

#2 @rachelbaker
5 years ago

  • Keywords close added

@Atari-Frosch I haven't seen anyone else reporting this issue, and cannot reproduce it. If you can provide the additional details requested by @swissspidy above, please do so.

#3 @rachelbaker
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.