WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#35027 closed defect (bug) (worksforme)

Admin 404 error in WP 4.4 for some Sub-directory Installations

Reported by: joshuadnelson Owned by: dd32
Milestone: Priority: normal
Severity: normal Version: 4.4
Component: Administration Keywords: needs-patch
Focuses: administration Cc:
PR Number:

Description

In some sub-direction installations of WP, after upgrading to 4.4 the admin results in a 404 error. We've reproduced the issue, but have been unable to diagnose the cause: https://wordpress.org/support/topic/help-cannot-login-or-access-dashboard-after-wp-update-to-44.

I have a few other sites in sub-directories without issues, however the site in question with the issue has gone through all the typical methods of solving a 404 issue without avail. Others on the support ticket linked above have reported the same issue.

Change History (9)

#2 @SergeyBiryukov
4 years ago

  • Milestone changed from Awaiting Review to 4.4.1

#3 @peterwilsoncc
4 years ago

  • Keywords needs-patch added

This ticket was mentioned in Slack in #core by jorbin. View the logs.


4 years ago

#5 @jorbin
4 years ago

@dd32 - I saw on the comment thread you were getting in contact with one of the affected people. Anything to report from that conversation?

From the sounds of the support forum, this relates to file permissions but hasn't been root caused.

#6 @jorbin
4 years ago

  • Owner set to dd32
  • Status changed from new to assigned

#7 @dd32
4 years ago

  • Milestone 4.4.1 deleted
  • Resolution set to worksforme
  • Status changed from assigned to closed

I've been in touch with two affected users.
This doesn't appear to be a 4.4 issue.

In one case there was a bad cdn + security plugin blocking access.
In another (The reporter of this ticket) file permissions were wrong, seemingly caused by some change on the server.

Couldn't see any way to blame WordPress unfortunately.

#8 @iforceman
4 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I'm getting a 404 error when I click on either Updates or Plugins.

Is this similar to what is being reported? Please advise what to do.

#9 @dd32
4 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

@iforceman It's likely a hosting misconfiguration, you should check the permissions of the files on your account. I'll send you a follow up email shortly.

Note: See TracTickets for help on using tickets.