WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#35071 closed defect (bug) (worksforme)

upgrade 431 to 44 with twenty fourteen no left bar no footer

Reported by: zepolo Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4
Component: Bundled Theme Keywords: close
Focuses: Cc:

Description

With no plug in and no custom css :

appareance > widgets
after the upgrade not showing neither left bar nor footer only right bar

When inspect the html code the menu is there but not showing

What I have noticed :

  • version 4.4 with twenty fourteen : NO LEFT BAR SHOWING NO FOOTER
  • version 4.4 in database and previous version code site : only display left menu included in the theme twenty fourteen

Change History (8)

#1 @SergeyBiryukov
6 years ago

  • Component changed from Themes to Administration
  • Keywords close added

Hi @zepolo, welcome to Trac!

This sounds like an incomplete upgrade, a plugin conflict, or an insufficient memory issue.

Unfortunately, there's not much we can do from the WordPress core side until there are clear steps to reproduce the issue on a clean install.

Please continue with your topic on support forums.

#2 @zepolo
6 years ago

Hello,

Thanks for the quick answer.

When browsing the site no left bar no footer.

I have tried :

  • with no plug in
  • automatic install
  • manual install

No left bar no footer.
There is an incompatibility with the twenty fourteen.

Thanks.

Last edited 6 years ago by zepolo (previous) (diff)

#3 follow-up: @zepolo
6 years ago

I have found the "guilty code".

Through appareance > widgets I have a TEXT.
The code inside javascript made that the side left bar is not showing.

This only happen in the v 4.4 with twentyfourteen.

I also mention that in the admin the plugin supercache menu is completely left instead of centered.

#4 in reply to: ↑ 3 @SergeyBiryukov
6 years ago

Replying to zepolo:

Through appareance > widgets I have a TEXT.
The code inside javascript made that the side left bar is not showing.

Could you share the code?

#5 follow-up: @zepolo
6 years ago

Hi @SergeyBiryukov,
Here you are, the standard criteo script. I hope some one can help, thanks for all :

<script type='text/javascript'>
<!--//<![CDATA[
   document.MAX_ct0 ='';
   var m3_u = (location.protocol=='https:'?'https://cas.criteo.com/delivery/ajs.php?':'http://cas.criteo.com/delivery/ajs.php?');
   var m3_r = Math.floor(Math.random()*99999999999);
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("zoneid=123456");document.write("&amp;nodis=1");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location).substring(0,1600));
   if (document.context) document.write ("&context=" + escape(document.context));
   if ((typeof(document.MAX_ct0) != 'undefined') && (document.MAX_ct0.substring(0,4) == 'http')) {
       document.write ("&amp;ct0=" + escape(document.MAX_ct0));
   }
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
      document.write ("'></scr"+"ipt>");
//]]>-->
</script>

According to the place (1st, 2nd or so on ..) you put this code there is a problem with left bar or footer or both.
It could alter either the menu or the widgets in the left bar of the twentyfourteen.

Looking at the code of the page the leftbar was there but not showing in the browser.
At the beginning I was thinking about some css problem but I found nothing.

BUT it never breaks completely the rightbar even when included in it.

Without that big problem the update to 4.4 succeeded like a charm.
Thanks for all the people working so hard for WP.
Congratulations ;))

Last edited 6 years ago by zepolo (previous) (diff)

#6 in reply to: ↑ 5 @SergeyBiryukov
6 years ago

  • Component changed from Administration to Bundled Theme

Replying to zepolo:

According to the place (1st, 2nd or so on ..) you put this code there is a problem with left bar or footer or both.
It could alter either the menu or the widgets in the left bar of the twentyfourteen.

Thanks for the code. I've switched to Twenty Fourteen, pasted the code into a text widget and moved it to the top of the left sidebar, but still could not reproduce the issue in Chrome or Firefox. It does add a small delay when the page is loading, but that's about it.

I guess it might be a conflict with some other script on your site.

Last edited 6 years ago by SergeyBiryukov (previous) (diff)

#7 @zepolo
6 years ago

Ok thanks for the feedback.

You are right it could be a conflict with some other script.
I is hard when you do not have the same config to reproduce the facts.

If you try this, perhaps it will be the same bug in your test :
In the right side bar when I put the script in a text widget and I put a title then the "guilty script" the title of the widget with this code doesn't show and there is no black separation line.

Of course put several widgets in the right bar.

I also mention a gltch with the twentyfourteen theme :
in the admin menu when you open the plugin supercache its menu on the top is ok but the options page is completely right side instead of left side.

Thanks for all.

Last edited 6 years ago by zepolo (previous) (diff)

#8 @karmatosed
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

@zepolo I have tried to replicate this but can't. For now, lets close this up and if you can do some investigation that would be great. I have a feeling it's something relating to your site that is causing the clashes. We have an excellent resource of the support forums you can work through site specific issues in and perhaps this would be the best route if you are stuck.

If you do find a reproduceable bug then absolutely we can investigate and please open a new ticket so we can work on that with you and get a fix. Thanks for investigating though and taking the time to report a potential issue.

Note: See TracTickets for help on using tickets.