WordPress.org

Make WordPress Core

Opened 15 years ago

Closed 15 years ago

#3510 closed defect (bug) (fixed)

RTE should not change links like http://www.example.com/#foo to #foo

Reported by: KevinJB Owned by:
Milestone: 2.0.6 Priority: low
Severity: trivial Version: 2.0.5
Component: General Keywords:
Focuses: Cc:

Description

Wordpress converts Link URLS like http://www.example.com/#foo to just #foo, but if you do something like http://www.example.com/index.html#foo it leaves it alone.

Not sure whether this is a feature (?) or a bug, asked in #wordpress on irc.freenode.net and no one there knew what it was

Change History (2)

#1 @KevinJB
15 years ago

Looks like this is a problem with TinyMCE, as it works just fine with the WYSIWYG editor turned off :)

#2 @foolswisdom
15 years ago

  • Milestone changed from 2.2 to 2.0.6
  • Resolution set to fixed
  • Status changed from new to closed
  • Summary changed from Link URL's with '#' are changed. to RTE should not change links like http://www.example.com/#foo to #foo
  • Version set to 2.0.5

Closing as FIXED, confirmed bug in 2.0.6-RC1, but found it fixed in latest devel builds

ENV: 2.0.5+ r4672 (2.0.6-RC2)
and trunk build

Created link in RTE to http://www.example.com/#foo and it is left unchanged.

Note: See TracTickets for help on using tickets.