WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

Last modified 4 weeks ago

#35104 closed task (blessed) (fixed)

Update package.json devDependencies for WordPress 4.5

Reported by: jorbin Owned by: jorbin
Milestone: 4.5 Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords:
Focuses: Cc:

Description

This is a tracking ticket for all package.json version updates that will need to take place in WordPress 4.5. New packages or swapping of packages should go in seperate tickets.

Attachments (1)

35104.diff (857 bytes) - added by netweb 4 years ago.

Download all attachments as: .zip

Change History (23)

#1 @johnbillion
5 years ago

  • Version trunk deleted

#2 @netweb
4 years ago

@jorbin When do we want, rather need to do this? Should it be done for beta 1 this week?

If so, does /build need a npm-shrinkwrap.json file to coincide with the beta release? (See r36165)

#3 @mikeschroder
4 years ago

  • Owner set to jorbin
  • Status changed from new to assigned

#4 @jorbin
4 years ago

In 36860:

Update Autoprefixer to 6.3.3

See #35104

#5 @jorbin
4 years ago

In 36861:

Update grunt-contrib-clean from 0.6.0 → 1.0.0

see #35104

#6 @jorbin
4 years ago

In 36862:

Update grunt-contrib-compress ~0.14.0 → ~1.1.0

See #35104

#7 @jorbin
4 years ago

In 36863:

Update grunt-contrib-concat ~0.5.1 → ~1.0.0

see #35104

#8 @jorbin
4 years ago

In 36864:

Update grunt-contrib-copy ~0.8.2 → ~1.0.0

See #35104.

#9 @jorbin
4 years ago

In 36865:

Update grunt-contrib-cssmin ~0.14.0 → ~1.0.0

See #35104.

This ticket was mentioned in Slack in #core by chriscct7. View the logs.


4 years ago

#11 @chriscct7
4 years ago

Per trac discussion, there's a few more updates needed

"git-or-svn" can be updated from ~0.1.0 to ~0.1.1 (Installed: 0.1.1, Latest: 0.1.1)
"grunt-contrib-compress" can be updated from ~1.1.0 to ~1.1.1 (Installed: 1.1.0, Latest: 1.1.1)
"grunt-contrib-jshint" can be updated from ~0.11.3 to ~1.0.0 (Installed: 0.11.3, Latest: 1.0.0)
"grunt-contrib-qunit" can be updated from ~0.7.0 to ~1.0.1 (Installed: 0.7.0, Latest: 1.0.1)
"grunt-contrib-uglify" can be updated from ~0.10.0 to ~1.0.0 (Installed: 0.10.1, Latest: 1.0.0)
"grunt-includes" can be updated from ~0.5.1 to ~0.5.4 (Installed: 0.5.3, Latest: 0.5.4)
"grunt-postcss" can be updated from ~0.7.1 to ~0.8.0 (Installed: 0.7.1, Latest: 0.8.0)
"grunt-rtlcss" can be updated from ~1.6.0 to ~2.0.1 (Installed: 1.6.0, Latest: 2.0.1)
"matchdep" can be updated from ~1.0.0 to ~1.0.1 (Installed: 1.0.0, Latest: 1.0.1)

https://wordpress.slack.com/archives/core/p1457560541004535

@netweb
4 years ago

#12 @netweb
4 years ago

Replying to chriscct7:

Per trac discussion, there's a few more updates needed

"git-or-svn" can be updated from ~0.1.0 to ~0.1.1 (Installed: 0.1.1, Latest: 0.1.1)
"grunt-contrib-compress" can be updated from ~1.1.0 to ~1.1.1 (Installed: 1.1.0, Latest: 1.1.1)
"grunt-contrib-jshint" can be updated from ~0.11.3 to ~1.0.0 (Installed: 0.11.3, Latest: 1.0.0)
"grunt-contrib-qunit" can be updated from ~0.7.0 to ~1.0.1 (Installed: 0.7.0, Latest: 1.0.1)
"grunt-contrib-uglify" can be updated from ~0.10.0 to ~1.0.0 (Installed: 0.10.1, Latest: 1.0.0)
"grunt-includes" can be updated from ~0.5.1 to ~0.5.4 (Installed: 0.5.3, Latest: 0.5.4)
"grunt-postcss" can be updated from ~0.7.1 to ~0.8.0 (Installed: 0.7.1, Latest: 0.8.0)
"grunt-rtlcss" can be updated from ~1.6.0 to ~2.0.1 (Installed: 1.6.0, Latest: 2.0.1)
"matchdep" can be updated from ~1.0.0 to ~1.0.1 (Installed: 1.0.0, Latest: 1.0.1)

https://wordpress.slack.com/archives/core/p1457560541004535


These 4 do not need updating as they are already covered by the semantic versioning in place in package.json

"git-or-svn" can be updated from ~0.1.0 to ~0.1.1 (Installed: 0.1.1, Latest: 0.1.1)
"grunt-contrib-compress" can be updated from ~1.1.0 to ~1.1.1 (Installed: 1.1.0, Latest: 1.1.1)
"grunt-includes" can be updated from ~0.5.1 to ~0.5.4 (Installed: 0.5.3, Latest: 0.5.4)
"matchdep" can be updated from ~1.0.0 to ~1.0.1 (Installed: 1.0.0, Latest: 1.0.1)


These 4 can be upgraded safely without issue and are included in 35104.diff

JSHint https://github.com/gruntjs/grunt-contrib-jshint/compare/v0.11.3...v1.0.0
Uglify https://github.com/gruntjs/grunt-contrib-uglify/compare/v0.10.0...v1.0.0
QUnit https://github.com/gruntjs/grunt-contrib-qunit/compare/v0.7.0...v1.0.1
PostCSS https://github.com/nDmitry/grunt-postcss/compare/v0.7.0...v0.8.0

"grunt-contrib-jshint" can be updated from ~0.11.3 to ~1.0.0 (Installed: 0.11.3, Latest: 1.0.0)
"grunt-contrib-uglify" can be updated from ~0.10.0 to ~1.0.0 (Installed: 0.10.1, Latest: 1.0.0)
"grunt-contrib-qunit" can be updated from ~0.7.0 to ~1.0.1 (Installed: 0.7.0, Latest: 1.0.1)
"grunt-postcss" can be updated from ~0.7.1 to ~0.8.0 (Installed: 0.7.1, Latest: 0.8.0)


The last one on the list is RTLCSS

"grunt-rtlcss" can be updated from ~1.6.0 to ~2.0.1 (Installed: 1.6.0, Latest: 2.0.1)

This requires a bit of work to convert the existing dashicons properties option of the task to an RTLCSS Plugin

I believe @ocean90 your somewhat familiar with these RTLCSS v2.x.x changes per Slack here?

#13 @ocean90
4 years ago

In 36935:

Build Tools: Update grunt-rtlcss ~1.6.0 → ~2.0.1.

This updates the underlying RTLCSS framework to 2.0 which provides new options and config settings, see https://github.com/MohammadYounes/rtlcss/blob/master/CHANGELOG.md#200---18-feb-2016.

See #35104.

Build: https://build.trac.wordpress.org/changeset/36903

#14 @jorbin
4 years ago

In 36978:

Update grunt-postcss ~0.7.1 → ~0.8.0

See #35104

#15 @jorbin
4 years ago

In 36979:

Update grunt-browserify ~4.0.1 → ~5.0.0

Updates underlying broweserify library to 13.0.0

See #35104

#16 @jorbin
4 years ago

In 36980:

Revert r36978

grunt-postcss Dropped nodejs 0.10 support and this is causing builds to fail. Revert until we bump minimum node version.

See #35104

This ticket was mentioned in Slack in #core by chriscct7. View the logs.


4 years ago

#18 @jorbin
4 years ago

In 37017:

Bump grunt-contrib-jshint ~0.11.3 → ~1.0.0

See #35104

#19 @jorbin
4 years ago

In 37019:

Bump grunt-contrib-watch ~0.6.1 → ~1.0.0

See #35104

#20 @jorbin
4 years ago

In 37020:

Bump grunt-contrib-qunit ~0.7.0 → ~1.1.0

See #35104

#21 @jorbin
4 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

Skipping a few packages:

grunt-postcss - requrires a new version of node than we currently require. see https://core.trac.wordpress.org/ticket/35104#comment:16

grunt-contrib-uglify - Changes all minified JS files. Would prefer this happening earlier in a cycle so it gets enough testing.

If we notice any major issues with dependencies, we should create tickets. Otherwise, let's consider our dev dependencies locked for 4.5

#22 @SergeyBiryukov
4 weeks ago

In 48030:

Build/Test Tools: Bump grunt-contrib-qunit ~0.7.0 → ~1.1.0.

Merges [37020] to the 4.4 branch.
Fixes #50371. See #35104.

Note: See TracTickets for help on using tickets.