WordPress.org

Make WordPress Core

Opened 3 years ago

Last modified 12 days ago

#35158 reopened defect (bug)

Titles Change over to Admin User Name

Reported by: yogaman5020 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4
Component: Editor Keywords:
Focuses: Cc:

Description

When I open the page and post editor, the contents of the title field changes over from the name of the page or post to the admin user name. The change takes about 2 - 3 seconds. I can watch it before my eyes. I turned off all plugins, and changed over to the Twenty Sixteen theme and the problem persisted. The problem occurred after updating to Version 4.4. When I look in the WP Admin at the Post or Page table, the titles of my entries appear fine. When I open each post or page in Quick Edit mode, I observe the post and page titles correctly. The problem only occurs in the editor. The result is that when view the page or post, the Admin User name appears in place of the post or page title.

I'm developing locally using Desktop Server 3.8 on top of XAMPP. App runs on Mac OS X 10.9.5 (Mavericks).

Attachments (3)

3_Page editor title reverts to admin user name.png (103.7 KB) - added by yogaman5020 3 years ago.
Screenshot demonstrating issue.
2_Quick Edit Mode .png (68.5 KB) - added by yogaman5020 3 years ago.
1_WP Admin Page List - normal view.png (87.1 KB) - added by yogaman5020 3 years ago.

Download all attachments as: .zip

Change History (11)

@yogaman5020
3 years ago

Screenshot demonstrating issue.

#1 @SergeyBiryukov
3 years ago

  • Keywords reporter-feedback added

Hi @yogaman5020, welcome to Trac!

Do you have some kind of a password manager extension installed in your browser? Seems like it might be interfering with the page.

#2 @yogaman5020
3 years ago

In fact, I do have a password manager installed in my browser, and it was on the entire time I was working on the site. Very astute of you! Good sleuthing! I turned the PW mgr. off and the problem resolved. You can close out this ticket.

#3 @SergeyBiryukov
3 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

#4 @johnbillion
3 years ago

@yogaman5020 Which password manager are you using?

#5 follow-up: @yogaman5020
3 years ago

@johnbillion: LastPass. Been using them for a couple of years. I learned that they recently were purchased by LogMeIn. Some hard-core WP devs think that this is practically the end of the world and are vowing to switch to OnePassword, or another product. To me, the automatic form filling in title fields while developing locally in WP is just an annoyance. I've turned off the PW manager for now so I can work without interference. If Automattic thinks this is something they can take on and fix, well, bully for you!

#6 in reply to: ↑ 5 @johnbillion
3 years ago

Replying to yogaman5020:

@johnbillion: LastPass. Been using them for a couple of years.

Interesting, I've been using LastPass too for several years and I've not seen this problem. I might have a play around with the settings and see if I can reproduce it.

#7 @yogaman5020
3 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Hi John,

I know this ticket is closed. But the problem I reported to you is continuing in my local dev environment (DesktopServer v.3.8), and popping up on different admin screens. [No longer the page/post editor as I reported earlier.] In some cases, existing data inputs get overwritten with the site admin user name. In other cases, empty input fields are autofilled by the PW manager with the admin user name. It's an annoying feature that just started after I updated WP to v.4.4. It also creates confusion, because I'm never sure if the existing DB settings for that admin screen is correct. I think you ought to reopen this ticket and dig deeper into the problem to see if it can be resolved.

Robert (@yogaman5020)

Last edited 3 years ago by yogaman5020 (previous) (diff)

#8 @SergeyBiryukov
3 years ago

  • Milestone set to Awaiting Review
Note: See TracTickets for help on using tickets.