Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#35266 closed defect (bug) (duplicate)

Set appropriate Cache-Control and/or Pragma headers on the front-end

Reported by: tomdxw's profile tomdxw Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4
Component: Comments Keywords: needs-patch good-first-bug
Focuses: Cc:

Description

When signed-out and viewing a post with comments enabled, WordPress pre-fills form values based on comment_author_* and comment_author_email_* cookies. As these pages are being generated on a per-user basis, shouldn't they also send Cache-Control headers to prevent caches like varnish from caching these pages and subsequently sending the contents of these pages to the wrong users?

Change History (4)

#1 @dd32
8 years ago

  • Keywords needs-patch good-first-bug added

This seems like a sane improvement.
If the output of a page is determined by a cookie, it definitely should have some kind of cache-control specified IMHO,

#3 @thomaswm
8 years ago

I think this is a duplicate of #16612.

#4 @DrewAPicture
8 years ago

  • Component changed from General to Comments
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #16612.

Note: See TracTickets for help on using tickets.