WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#35297 closed defect (bug) (duplicate)

Category links wrong in multisite installation

Reported by: grey280 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6
Component: Taxonomy Keywords:
Focuses: administration, multisite Cc:

Description

In a multisite installation, on the origin site (from which the multisite installation was configured), the 'view' links in the category list of the administration menu (wp-admin/edit-tags.php?taxonomy=category) link to /blog/category/category-name/, rather than /category/category-name/
This leads to either 404 errors or (theme-dependent) some strange redirect behavior.

Change History (4)

#1 @swissspidy
4 years ago

  • Component changed from Administration to Taxonomy

#2 follow-up: @Chouby
4 years ago

Could it be a duplicate of #20171?

#3 in reply to: ↑ 2 @grey280
4 years ago

Replying to Chouby:

Could it be a duplicate of #20171?

Could be the same error, though I'm not certain - this only crops up on the main site in a subdomain-type install, whereas #20171 is in reference to directory-type install and, from what I can tell, applies to all blogs on the network.

#4 @jeremyfelt
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the ticket @grey280. This is a duplicate of #20171. If you visit Settings -> Permalinks in the admin of the main site and then try visiting the category page again, you shouldn't get a 404.

Note: See TracTickets for help on using tickets.