WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#35345 closed defect (bug) (duplicate)

Multisite unable to update plugins

Reported by: tigerton Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4.1
Component: Upgrade/Install Keywords:
Focuses: multisite Cc:

Description

When i try to update plugins in multisite (as network admin in network settings) on a -Windows server- i get stuck when plugins try to generate or create the maintenance file.

I have found a possible fix from this previous thread,
https://wordpress.org/support/topic/unable-to-update-plugins-after-upgrade-to-42/page/3

Our fix is this,

Row 155:
wp-admin/includes/file.php
Change to:

if ( empty( $filename ) || '.' == $filename || DIRECTORY_SEPARATOR == $filename ) {

Courtesy of DionDesign found in the previous thread.

Kind regards
Tony

Change History (5)

#1 @swissspidy
4 years ago

  • Component changed from General to Upgrade/Install
  • Focuses administration removed

#2 @dd32
4 years ago

This is a duplicate of #33999 and something that i've never been able to reproduce.

@tigerton Would it be possible for you to provide the input to the function, and the value of $filename on each iteration of it?

Switching to DIRECTORY_SEPARATOR straight out is likely to break in some scenario's, but if there's some examples which show the actual variable trace then adding \\ to the checks (there and everywhere else) is possible.

#3 @tigerton
4 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Hi,

Thanks for getting back. Yes i see the duplicate ticket but it was closed without a solution (understandable as of my conclusion below).

I have been unsuccessful with debug.log but i found that this might be due to a timeout/lack of memory situation and not actually filename/structure issue.

Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 65488 bytes) in C:\inetpub\wwwroot\wp-admin\includes\file.php on line 170

I had less than 800MB left on HDD and Ram was 4GB but maxed out. 10 extra GB HDD and 1GB more RAM did the trick.

*
Update: Issue still remain after massive increase of GB.
*

Last edited 4 years ago by tigerton (previous) (diff)

#4 @swissspidy
4 years ago

  • Resolution changed from invalid to duplicate

Duplicate of #33999.

#5 @SergeyBiryukov
4 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.