WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 8 years ago

#3540 closed defect (bug) (fixed)

Scroll bar partially hidden in Code editor

Reported by: lambic Owned by: andy
Milestone: 2.3 Priority: high
Severity: minor Version: 2.1
Component: Administration Keywords:
Focuses: Cc:

Description (last modified by markjaquith)

If I switch from Visual to Code in the editor, the scrollbar is cut off by the sidebar.

Windows, Firefox 2.0.0.1, WP 2.1beta1.


johnbillion @ #3684 provides screenshots (at that ticket) and says:

The right hand side of the "Page Content" and "Post Content" textarea gets chopped off by approximately half the width of the scrollbar when you change from the Visual tab to the Code tab and the content makes the textarea scroll.

In Firefox 2.0 on Windows XP SP2 the scrollbar gets obscured by approximately half the width of the scrollbar.

In IE6 On Windows XP SP2 the scrollbar is pushed right up against the right-hand side option boxes by approximately the whole width of the scrollbar.

Steps to reproduce:

  1. Go to Manage -> Posts and click on 'edit' on a post.
  1. On the editing page, make sure there is plenty of content in the post, so that the post box scrollbar appears. Switch to the 'Code' tab (and, optionally, back and forth between the tabs) and you'll see that the textarea is too wide for the area it's in.

Change History (11)

comment:1 @ryan9 years ago

Confirmed.

comment:2 @foolswisdom9 years ago

  • Milestone changed from 2.2 to 2.1

comment:3 @ryan9 years ago

  • Owner changed from anonymous to andy

comment:4 @foolswisdom9 years ago

  • Priority changed from low to high

Still repro with Firefox 2 on WinXP & Linux

Raising Priority: High
as it looks sloppy for release

comment:5 @markjaquith9 years ago

The only way I can fix it (Firefox 2 on OS X) is to set padding: 0; for #postdivrich #content

This, of course, kills the padding on the <textarea /> which makes it look different than the usual (RTE off in preferences) <textarea />

Something about the "TinyMCE-ization" of the <textarea /> is lingering, even it is switched off.

comment:6 @foolswisdom9 years ago

  • Milestone changed from 2.1 to 2.1.1

comment:7 @markjaquith9 years ago

  • Description modified (diff)

comment:8 @Nazgul8 years ago

  • Milestone changed from 2.1.1 to 2.1.2

comment:9 @foolswisdom8 years ago

  • Milestone changed from 2.1.3 to 2.2

comment:10 @foolswisdom8 years ago

  • Milestone changed from 2.2 to 2.3

comment:11 @andy8 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Tested with Firefox 2.0.0.1 and WP r5977. Problem does not appear.

Note: See TracTickets for help on using tickets.