WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#35403 closed feature request (duplicate)

Add support for a separate admin language

Reported by: rasmusbe Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: ui, administration Cc:

Description

I would like to suggest a change to use separate language switchers for the site and the admin pages.

Use case:
An english speaking administator is managing a swedish site. The content is created by an swedish speaking translator, but the english speaking administrator also has to use the site. Right now both the site and the admin pages has to be in swedish which makes it hard for the administrator to use the interface.

Proposed changes:

  • The admin interface uses a function get_admin_locale instead of get_locale. get_admin_locale gets its setting from an option with key ADMINLANG, but falls back to WPLANG option if missing.
  • A filter admin_locale is used in the get_admin_locale function to support extended functionality. (For example user specific settings)

Change History (2)

This ticket was mentioned in Slack in #core by rasmus. View the logs.


4 years ago

#2 @ocean90
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #29783.

Note: See TracTickets for help on using tickets.