WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#35440 closed defect (bug) (duplicate)

No phantomjs binary available for linux/arm architecture

Reported by: henry.wright Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords:
Focuses: Cc:

Description

When I run sudo npm install, I get the error:

PhantomJS not found on PATH
Unexpected platform or architecture: linux/arm
It seems there is no binary available for your platform/architecture
Try to install PhantomJS globally

My system architecture is armhf.

I've opened an issue on the phantomjs GitHub repo but thought I'd report here because this results in a failed build.

Ref: https://github.com/Medium/phantomjs/issues/433

Change History (1)

#1 @dd32
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Marking as a duplicate of #35438 as the end-result is the same. Linux-arm packages aren't available at this time, and it's not something within our control. Hopefully phantomjs builds get created for your platform soon.

Note: See TracTickets for help on using tickets.