WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#35441 closed enhancement (duplicate)

Support php-mysqlnd

Reported by: nexurium Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6
Component: Database Keywords:
Focuses: Cc:

Description

In wp-includes/load.php at line 136 replace

if ( ! extension_loaded( 'mysql' ) && ! extension_loaded( 'mysqli' ) && ! file_exists( WP_CONTENT_DIR . '/db.php' ) ) {

by

if ( ! extension_loaded( 'mysql' ) && ! extension_loaded( 'mysqli' ) && ! extension_loaded( 'mysqlnd' ) && ! file_exists( WP_CONTENT_DIR . '/db.php' ) ) {

Maybe add also the support for php-mysqlnd-ms

Change History (4)

#1 @nexurium
6 years ago

  • Keywords has-patch added

#2 @swissspidy
6 years ago

  • Keywords has-patch removed
  • Type changed from defect (bug) to enhancement

#3 @nexurium
6 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #33261.

#4 @netweb
6 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.