WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#35515 closed defect (bug) (duplicate)

Required asterisk (*) is missing with the comment label in the comment form

Reported by: rianrietveld Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Comments Keywords: has-patch
Focuses: ui, accessibility Cc:

Description

With the core comment form the asterisk (*) is missing in the label for the comment.

The field is required, if you don't fill out the comment the error message "ERROR: please type a comment." is show. All the ARIA is correct (aria-required="true" required="required"). Only the * is missing in the label.

Attached patch adds to the label:

<span class="required">*</span>

Attachments (2)

35515.patch (1.6 KB) - added by rianrietveld 5 years ago.
adds * to label comment textarea
missing-asterisk.png (39.7 KB) - added by rianrietveld 5 years ago.
Image of comment form with missing asterisk, theme is Twenty Sixteen

Download all attachments as: .zip

Change History (7)

@rianrietveld
5 years ago

adds * to label comment textarea

@rianrietveld
5 years ago

Image of comment form with missing asterisk, theme is Twenty Sixteen

#1 @rianrietveld
5 years ago

  • Component changed from General to Comments

#2 @ocean90
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version trunk deleted

Duplicate of #16206.

#3 follow-up: @rianrietveld
5 years ago

@ocean90
Thank you for pointing me to #16206.
I would like to discuss this further from an accessibility point of view.
Required fields need to be indicated.
I agree that it's obvious, but if you use an asteriks do it consistent.

What would be the best option: open this ticket again or 16206?

Last edited 5 years ago by rianrietveld (previous) (diff)

#4 in reply to: ↑ 3 @ocean90
5 years ago

Replying to rianrietveld:

The discussion should continue on #16206. Feel free to reopen it although discussions can happen on closed tickets as well.

#5 @rianrietveld
5 years ago

Thanks :-) I reopened #16206

Note: See TracTickets for help on using tickets.