WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#3553 closed defect (bug) (invalid)

MuWordPress strips out the port in the domain name

Reported by: almt Owned by:
Milestone: Priority: normal
Severity: major Version:
Component: Administration Keywords:
Focuses: Cc:

Description

I'm unable to access the login pages, due to excessive rewrites. That's because my apache server uses a non-standard port, 8000, as I'm not running it as root.

Commenting out this line in wpmu-settings.php solves the problem (sort of):

$domain = preg_replace('/:.*$/', , $domain); Strip ports

However, I'm still not able to login. I can tell it is able to authenticate my password, but it keeps bringing me back to the login page.

I do have cookies enabled and my web site does not start with "www".

I did not change any other scripts.

Change History (3)

comment:1 follow-up: @foolswisdom8 years ago

Please start by including all of your environment info including WordPress version and build?

Does the problem reproduce in non-Mu WordPress? If it is Mu specific then please open a ticket at http://trac.mu.wordpress.org

comment:2 in reply to: ↑ 1 @almt8 years ago

Replying to foolswisdom:

Please start by including all of your environment info including WordPress version and build?

I'm new here, how does one dump the environment?

I'm running muwordpress1.0, RedHat8.0, Apache 1.3.26 with mod_rewrite compiled in. Since the problem is with muwordpress, I'll post a muwordpress ticket.

comment:3 @Nazgul8 years ago

  • Milestone 2.2 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Closing this one as it has been moved to MU. (http://trac.mu.wordpress.org/ticket/220)

Note: See TracTickets for help on using tickets.