WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#35572 closed defect (bug) (duplicate)

Custom $comment & page & per_page in wp_list_comments hide all

Reported by: sibputnik Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4.1
Component: Comments Keywords:
Focuses: Cc:

Description

This is a follow-up to #35175.

Hi. After fix above, when u pass custom $comments to wp_list_comments and set custom page and per_page, nothing is shown. I found in when try use "Show All Comments" plugin https://wordpress.org/plugins/show-all-comments-in-one-page/ . It show all comments in single page.

As seen in code, this plugin get all comments and pass it to wp_list_comments. Because it use custom page and per_page, wp_list_comments fetch comments again for current page. Also, it is no comments in page and we have empty list.

I do not know right way to fix this. May be custom field in wp_list_comments or any other way to detect custom $comment, that not need to be changed.

Change History (2)

#1 @sibputnik
5 years ago

Also paginate_comments_links not worsk in this case, case use only current page.

#2 @boonebgorges
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @sibputnik - Welcome to WordPress Trac, and thanks for the ticket.

It looks like this is a duplicate of #35356, which has been fixed in trunk and will be part of 4.4.2. If you find that the problem is still occurring when testing against the latest branch/trunk (don't try manually applying the patch from #35356, as it depends on a couple of other changesets), please feel free to reopen with details. Thanks!

Note: See TracTickets for help on using tickets.