WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 16 months ago

Last modified 16 months ago

#35582 closed enhancement (duplicate)

Introduce wp_parse_slug_list()

Reported by: danielbachhuber Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: has-patch has-unit-tests
Focuses: Cc:

Description

Same as wp_parse_id_list(), but deals with sets of slug-like values.

Attachments (1)

35582.1.diff (1.7 KB) - added by danielbachhuber 2 years ago.

Download all attachments as: .zip

Change History (7)

This ticket was mentioned in Slack in #core by danielbachhuber. View the logs.


2 years ago

This ticket was mentioned in Slack in #core by chriscct7. View the logs.


2 years ago

#3 @chriscct7
2 years ago

@danielbachhuber what needs to happen on this?

#4 @danielbachhuber
2 years ago

  • Milestone changed from 4.5 to Future Release

I want to use this for https://github.com/WP-API/WP-API/issues/386, but the patch doesn't need to land yet.

#5 @swissspidy
16 months ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #38373.

This has been introduced together with the REST API content endpoints in [38832].

#6 @swissspidy
16 months ago

In 40044:

General: Add tests for wp_parse_slug_list().

Props danielbachhuber.
See #35582.

Note: See TracTickets for help on using tickets.