WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 17 months ago

Last modified 17 months ago

#35613 closed enhancement (duplicate)

Add granularity to REST API embeds

Reported by: jnylen0 Owned by: joehoyle
Milestone: Priority: normal
Severity: normal Version:
Component: REST API Keywords: needs-patch needs-unit-tests
Focuses: performance Cc:

Description

Currently ?_embed is all or nothing. It'd be good to have some granularity here, for example specifying ?_embed=author if we need just the post author but don’t want the performance hit of embedding everything else.

@joehoyle wrote a plugin for this ( https://gist.github.com/joehoyle/12e37c293adf2bb0ea1b ) and mentioned that it will be easier to use after #34729 lands.

Change History (9)

This ticket was mentioned in Slack in #core-restapi by jnylen. View the logs.


2 years ago

#2 @danielbachhuber
2 years ago

  • Keywords needs-patch needs-unit-tests added
  • Milestone changed from Awaiting Review to 4.5

This ticket was mentioned in Slack in #core by chriscct7. View the logs.


2 years ago

#4 @chriscct7
2 years ago

  • Owner set to joehoyle
  • Status changed from new to assigned

This ticket was mentioned in Slack in #core by jorbin. View the logs.


2 years ago

#6 @jorbin
2 years ago

  • Milestone changed from 4.5 to Future Release

#7 @chriscct7
2 years ago

  • Version trunk deleted

#8 @jnylen0
17 months ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #39696.

This ticket was mentioned in Slack in #core-restapi by jnylen. View the logs.


17 months ago

Note: See TracTickets for help on using tickets.