Make WordPress Core

Opened 8 years ago

Closed 2 years ago

Last modified 2 years ago

#35726 closed feature request (duplicate)

Add .webp support to WP_Image_Editor_GD

Reported by: markoheijnen's profile markoheijnen Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords:
Focuses: Cc:

Description

Since GD has a imagewebp function now, it would be great to integrate that into WordPress as well.
It's not something core will use but it will be nice for plugins to use the WordPress API instead of building there own solution.

Attachments (1)

35726.patch (1.3 KB) - added by markoheijnen 8 years ago.
Works only when no actions are applied

Download all attachments as: .zip

Change History (9)

This ticket was mentioned in Slack in #core-images by markoheijnen. View the logs.


8 years ago

@markoheijnen
8 years ago

Works only when no actions are applied

#2 @markoheijnen
8 years ago

Currently only works when no resizing has been done. I haven't pinpointed the problem yet.
Also there is no IMG_WEBP so I currently use function_exists('imagewebp') to check for it.

This ticket was mentioned in Slack in #core-media by joemcgill. View the logs.


4 years ago

#4 @spacedmonkey
4 years ago

  • Milestone set to Future Release

Related: #35725 #24718

This ticket was mentioned in Slack in #core-media by antpb. View the logs.


4 years ago

#6 @mitogh
2 years ago

Looks like something that can be already marked as closed cc @adamsilverstein due WebP is now supported since 5.8

#7 @adamsilverstein
2 years ago

  • Resolution set to fixed
  • Status changed from new to closed

@mitogh yes, closing.

Fixed in https://core.trac.wordpress.org/ticket/35725.

#8 @desrosj
2 years ago

  • Milestone Future Release deleted
  • Resolution changed from fixed to duplicate

Duplicate of #35725.

Note: See TracTickets for help on using tickets.