WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#35768 closed defect (bug) (duplicate)

Add New Post page: problem with publishing of a post with russian text in the post title

Reported by: antonrinas Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4.1
Component: Posts, Post Types Keywords:
Focuses: Cc:

Description

If to publish a new post with any word in Russian in the title field, then this post cannot be seen on front end.
I suppose the reason is in automatically generated "Permalink". In cases of English-German, English-French titles everithing works correct.

STEPS TO REPRODUCE

  1. Log in as admin.
  2. Go to Add New Post page.
  3. Type into title field: "Hello" means "Привет!" in Russian.
  4. Type into content area: "test".
  5. Click "Publish".
  6. Click "View post" in confirmation message.

EXPECTED RESULT
Created post is visible on front end.

ACTUAL RESULT
"Oops! That page can’t be found." (See annex)

Attachments (1)

CreateNewPost1.jpg (100.7 KB) - added by antonrinas 3 years ago.

Download all attachments as: .zip

Change History (3)

#1 @SergeyBiryukov
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #10249 and #17450.

#2 @SergeyBiryukov
3 years ago

To clarify, the issue only happens for PATH_INFO permalinks (/index.php/%postname%/ without mod_rewrite), and should eventually be resolved via the tickets linked above.

Regular permalinks (e.g. /%postname%/ with mod_rewrite) should work with Cyrillic slugs as expected.

Note: See TracTickets for help on using tickets.