WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#35814 closed defect (bug) (duplicate)

Protocol agnostic siteurl blocks admin area

Reported by: teebojamme Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.4
Component: General Keywords:
Focuses: Cc:

Description

For various (good, I promise) reasons, we have had to set our 'siteurl' option not only manually (with a define in wp-config.php), but also to a protocol neutral variant.
So, NOT: http[s]:SLASHSLASHwww.oursite.org but just: "SLASHSLASHwww.oursite.org"
This works really well until you need to login as that screws the COOKIE_HASH constant.

I have implemented a work around, but it would only work in this particular case.
Surely this could be made to work in a generic way?
And yes, SLASHSLASH, as you remove the normal ones....
(Dashboard reports we are on version 4.2.7 which is not in you dropdown)

Change History (1)

#1 @SergeyBiryukov
6 years ago

  • Component changed from Login and Registration to General
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #21153.

Version 0, edited 6 years ago by SergeyBiryukov (next)
Note: See TracTickets for help on using tickets.