WordPress.org

Make WordPress Core

#35818 closed enhancement (duplicate)

Add _deprecated_action and _deprecated_filter functions

Reported by: chriscct7 Owned by: chriscct7
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: needs-patch
Focuses: Cc:

Description

Similar to _deprecated_function, there should exist equivalent functions to deprecate filters and actions with. An example of a place where this could be used in core is #34625.

_deprecated_function is being used for this already in https://core.trac.wordpress.org/browser/trunk/src/wp-includes/class-wp-editor.php?rev=36483#L277, but adding new functions would allow for better context in the handling of these scenarios.

Change History (2)

#1 @chriscct7
17 months ago

  • Owner set to chriscct7
  • Status changed from new to assigned

#2 @DrewAPicture
16 months ago

  • Milestone 4.5 deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #10441.

See also #24429.

Note: See TracTickets for help on using tickets.