WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#35841 closed enhancement (duplicate)

Acceptance string deps

Reported by: sebastian.pisula Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Script Loader Keywords: has-patch
Focuses: Cc:

Description

I think that if my script file require only jquery then I should can set as string.

For example:

<?php
wp_enqueue_script( 'handle', 'url', 'jquery' );

Attachments (1)

35841.patch (3.5 KB) - added by sebastian.pisula 2 years ago.

Download all attachments as: .zip

Change History (4)

#1 @sebastian.pisula
2 years ago

  • Keywords has-patch added

#2 @sebastian.pisula
2 years ago

In wp-includes/class.wp-dependencies.php:489 is condition:

<?php
if ( ! is_array($this->deps) )
                        $this->deps = array();

#3 @ocean90
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #20683.

Note: See TracTickets for help on using tickets.