WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#35860 closed defect (bug) (worksforme)

Can't edit category slugs

Reported by: jshare Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4.2
Component: Quick/Bulk Edit Keywords: reporter-feedback
Focuses: administration Cc:

Description

I'm on Multisite.

I haven't needed to edit my categories in years, so I don't know when this bug appeared, but if I click Quick Edit on the categories page, the only option I have is to edit the category name.

In a clone environment of my site, I tried deactivating all plugins and that didn't change anything.

Attachments (1)

category-quick-edit-bug.gif (46.0 KB) - added by jshare 5 years ago.
Animated gif showing the lack of category name edit option

Download all attachments as: .zip

Change History (6)

@jshare
5 years ago

Animated gif showing the lack of category name edit option

#1 @jeremyfelt
5 years ago

  • Focuses multisite removed
  • Keywords reporter-feedback added

Hi @jshare, thanks for opening a ticket.

I'm not able to reproduce this in a multisite environment with Twenty Fifteen activated and no plugins installed on latest trunk.

Can you confirm the above behavior with all plugins disabled, all mu-plugins removed, and with a default theme activated? If so, are there any errors in your PHP logs or any console errors in the browser?

#2 @jshare
5 years ago

Sadly, I can confirm the above behavior with all plugins disabled, all mu-plugins removed (the mu-plugins dir is empty), and with a default theme activated (Twenty Fifteen).

On the Categories page, in Firefox's console, with all display options enabled (Net, CSS, JS, etc.), I only get CSS warnings, GETs and POSTS (for Ajax calls).

Nginx's error log doesn't have any entries for the past hour while I've been pecking around this.

Is there another log worth checking out?

Is it possible a wp-config setting is affecting this?

#3 @dd32
5 years ago

@jshare Do you have Global Terms enabled by chance?

Slug editing via the Create form and the Quick Edit functionality will be disabled in that case (as seen in your gif above)

#4 @jshare
5 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Nailed it!

The solution:

https://wordpress.org/support/topic/enable-global-terms?replies=6

Set global_terms_enabled = 0 in wp_sitemeta (the link incorrectly says in wp_sitecategories, although maybe it was true when that thread was open)

Thanks!

#5 @netweb
5 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.