Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#35938 closed defect (bug) (fixed)

Consistent naming of WordPress(.org) Plugin Directory

Reported by: mpol Owned by: SergeyBiryukov
Milestone: 4.6 Priority: normal
Severity: normal Version:
Component: Text Changes Keywords: has-patch commit
Focuses: Cc:


In the text strings the Plugin Directory is sometimes named WordPress Plugin Directory and sometimes WordPress.org Plugin Directory.
It would be a good thing to have a consistent name for this.
The same is true for the Theme Directory.

On the Dutch translation team we regard this as a product name, and translate it as such. I wouldn't dare to decide on if the name should be one or the other.
I think WordPress Plugin Directory is cleaner, shorter and more readable.
I think WordPress.org Plugin Directory makes a clear distinction from WordPress.com, allthough I wonder if that is even needed.

Attached are two patches, of which only one can be applied.
patch 1: wordpress_45_productnames.diff, uses WordPress Plugin Directory.
patch 2: wordpress_45_productnames_org.diff, uses WordPress.org Plugin directory.
The patches change the plugin directory name and the theme directory name.

Attachments (2)

wordpress_45_productnames.diff (8.0 KB) - added by mpol 6 years ago.
Set name to WordPress Plugin Directory
wordpress_45_productnames_org.diff (3.7 KB) - added by mpol 6 years ago.
set name to WordPress.org Plugin Directory

Download all attachments as: .zip

Change History (7)

6 years ago

Set name to WordPress Plugin Directory

6 years ago

set name to WordPress.org Plugin Directory

#1 @swissspidy
6 years ago

  • Keywords has-patch added
  • Version trunk deleted

#2 @ocean90
6 years ago

  • Keywords commit added
  • Milestone changed from Awaiting Review to 4.6

Asked Matt and wordpress_45_productnames.diff is good to go.

#3 @SergeyBiryukov
6 years ago

I think "WordPress.org Plugin Page" should be left as is, since it specifically refers to the WordPress.org page rather than a random "WordPress Plugin Page", which is very vague. Looks good to me otherwise.

#4 @SergeyBiryukov
6 years ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 37297:

Text Changes: Consistently refer to https://wordpress.org/plugins/ and https://wordpress.org/themes/ as WordPress Plugin Directory and WordPress Theme Directory, respectively.

Props mpol.
Fixes #35938.

#5 @SergeyBiryukov
5 years ago

In 38072:

Text Changes: After [37297], replace two more instances of "WordPress.org Plugin Directory" with "WordPress Plugin Directory".

See #35938.

Note: See TracTickets for help on using tickets.