WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#35967 closed defect (bug) (duplicate)

Stuck in maintenance mode during plugin update.

Reported by: paaljoachim Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

I notice a few trac ticket that mentions this issue that comes up when I am about to create this ticket. As I am not sure which are valid so I decided to create a new ticket for this matter.

#13988
#25655
#13721
#1073
#12947
#7819

Just now I was stuck in an update loop that I did not get out of. I found an article mentioning deleting the .maintenance file in the root of the site. I deleted the file and the site is back in place.

I am hoping that this is an issue that will soon be resolved. As the full site stops up and gets stuck in maintenance mode because of an update. Updating really should be in a tiny box (somekind of modul) and when the update is finished it should then be in place for the full site.

Again hopefully this has been addressed for 4.5. Or can be taken care off fairly soon.

Change History (1)

#1 @dd32
6 years ago

  • Component changed from General to Upgrade/Install
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This is most likely caused by #28013 where the FTP layer cannot see the . prefixed files.

I'm going to mark this as a duplicate of that, although I'm fairly certain there's another open ticket around the same issue.

Note: See TracTickets for help on using tickets.