Make WordPress Core

Changes between Initial Version and Version 1 of Ticket #35973


Ignore:
Timestamp:
02/27/2016 05:37:45 AM (8 years ago)
Author:
SergeyBiryukov
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #35973 – Description

    initial v1  
    22
    33I am using
     4{{{
    45Array
    56(
     
    78    [versionString] => ImageMagick 6.7.7-10 2014-03-08 Q16 http://www.imagemagick.org
    89)
    9 
     10}}}
    1011in /wp-includes/class-wp-image-editor-imagick.php line 57-75 you list the required methods WP needs in imagick to later check using array_diff.
    1112The problem is that you use old capitalisation e.g. getimage but Imagick lately (since at least 1 year already) uses getImage, writeImage,... so this will cause that imagick is never used.
    12 
     13{{{
    1314Array
    1415(
     
    2829    [16] => flopimage
    2930)
    30 
    31 As I saw activity in here: https://core.trac.wordpress.org/ticket/21668 only a couple hours ago by an admin after years of inactivity but dont know how to get into the slack conversation, I opened a ticket here. Also it would be nice if you would finally support progressive jpegs as stated in that ticket.
     31}}}
     32As I saw activity in here: #21668 only a couple hours ago by an admin after years of inactivity but dont know how to get into the slack conversation, I opened a ticket here. Also it would be nice if you would finally support progressive jpegs as stated in that ticket.