WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 6 years ago

Last modified 6 years ago

#3603 closed defect (bug) (duplicate)

end-of-comment markers converted to em-dash

Reported by: nickshanks Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.1
Component: Formatting Keywords:
Focuses: Cc:

Description

Enter the following in a new post:

string1 <!-- string2
<ol/>
--> string3

You will get the output:

<p>string1 <!-- string2</p>
<ol/>
&#8211;> string3</p>

I don't know if other block-level elements suffer this same fate, but this is not even well-formed output!

Attachments (1)

3603.diff (1014 bytes) - added by Nazgul 10 years ago.

Download all attachments as: .zip

Change History (14)

#1 @nickshanks
10 years ago

Enter the following in a new post:

{{{string1 <!-- string2
<ol/>
--> string3}}}

You will get the output:

{{{<p>string1 <!-- string2</p>
<ol/>
&#8211;> string3</p>}}}

I don't know if other block-level elements suffer this same fate, but this is not even well-formed output!
}}}

#2 @nickshanks
10 years ago

trac is broken. i give up :P

#3 @foolswisdom
10 years ago

  • Milestone changed from 2.2 to 2.1

Confirmed bug
ENV: 2.1-beta r44759

Seems to gooble the -- whenever there is an html tag in the comment.

Setting milestone as 2.1 as it seems better to disable em-dashing then have this behavior.

#4 @foolswisdom
10 years ago

  • Milestone changed from 2.1 to 2.2

@Nazgul
10 years ago

#5 @Nazgul
10 years ago

  • Keywords has-patch added

#6 @foolswisdom
10 years ago

  • Milestone changed from 2.2 to 2.3

#7 @Nazgul
10 years ago

  • Milestone changed from 2.3 to 2.4

#8 @Nazgul
10 years ago

  • Keywords needs-patch added; has-patch removed

Did some more testing. Although my patch fixes the problem it introduces others, so please ignore it.

Also closed #5073 as a duplicate of this bug.

#9 @Denis-de-Bernardy
8 years ago

  • Component changed from General to Formatting
  • Owner anonymous deleted

#10 @hakre
8 years ago

It is not possible to fix those things in wordpress. I suggest closing this as wontfix.

If you do not think so, please provide a patch that is actually fixing the issue and not breaking anything else.

#11 @azaozz
7 years ago

  • Milestone changed from 2.9 to Future Release

#12 @solarissmoke
6 years ago

  • Keywords needs-patch removed
  • Resolution set to duplicate
  • Status changed from new to closed

#8912 - that one seems more active

#13 @scribu
6 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.