WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#36032 closed defect (bug) (invalid)

Twenty Fourteen: Header Image not responsive for RTL site

Reported by: benchilcote Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4.2
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

For sites using RTL languages on twenty fourteen, the header image is not responsive - as it is with LTR languages.

This issues was discovered on a WordPress.com website and underwent the same testing as below with the same results.

On my test site, using WP 4.2.2 (most recent), I am using an uncropped header image (1260x166). When I set the language to Hebrew (RTL) and decrease the browser window size, the Header Image pushes off the page instead of resizing (See first image). When I set the language to English, the Header Image resizes (see second image)

I got the same results on several other RTL languages.

Small screen view using Hebrew Language (RTL)
https://cldup.com/DQ8h9OR0cP.png

Small screen view using English Language
https://cldup.com/bNHUaoIYoW.png

Change History (2)

#1 @SergeyBiryukov
4 years ago

Hi @benchilcote, thanks for the report.

I could not reproduce the issue on a clean install with Twenty Fourteen. Could it be specific to WordPress.com?

#2 @iamtakashi
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

I couldn't reproduce this either. I don't think this is the theme specific issue, and I'd suggest to close this as "worksforme".

Note: See TracTickets for help on using tickets.