WordPress.org

Make WordPress Core

Opened 2 years ago

Last modified 2 months ago

#36228 reopened enhancement

Uncheck "uncategorized" when you select a category

Reported by: melchoyce Owned by:
Milestone: 5.0 Priority: normal
Severity: normal Version:
Component: Taxonomy Keywords:
Focuses: administration Cc:

Description

One of my assorted WordPress pet peeves is when I select a category for my post, and still have to uncheck "uncategorized." If you haven't changed your default category from Uncategorized, you probably don't want to continue using it once you assign a new category to your post. We should automatically uncheck "uncategorized" when you pick an actual category.

Change History (11)

#1 @SergeyBiryukov
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14901.

This ticket was mentioned in Slack in #design by karmatosed. View the logs.


11 months ago

#3 @karmatosed
11 months ago

+1 for this. We really should actually I think go a step further and have 'uncategorized' not checked at all. This would really help avoid so many posts around with this just added without being wanted.

#4 @zakkath
11 months ago

+1 as well. I agreed with @karmatosed that it should be unchecked if even displayed at all. Maybe have the default save_post action set it if no other category is selected and, after that, have it show up?

#5 @knutsp
11 months ago

You mean always uncheck the default category when another is added?

Here, there is no "Uncategorized", but a translated one meaning something like this. A "News" category, translated to my language, is the default one.

The workflow (routine) here is to uncheck the News category for non-news post, and at the same time add another, or keep both the News category and add another (two or more categories).

If this goes in, will it be a way to keep the default category along with others?

#6 @karmatosed
4 months ago

This came up again in user research. Time and time again users are falling into the trap because we tick this on. We really should just get this in.

#7 @netweb
4 months ago

  • Milestone set to Awaiting Review
  • Resolution duplicate deleted
  • Status changed from closed to reopened

Related: https://github.com/WordPress/gutenberg/issues/4931: Do not check uncategorized by default

#8 @danielbachhuber
2 months ago

I think it makes more sense to replicate core's existing behavior in Gutenberg.

While the UX is less than ideal (I've personally set my default category to Categorized), I don't think it's worth the effort to try and remove the concept of default categories in core.

#9 @karmatosed
2 months ago

@danielbachhuber this has come up time and time again with multiple people asking for it. We seem to be having the same discussion on the Gutenberg issue, I'll try and avoid repeating myself but it is important we don't assume everyone knows how to change the default category, they simply do not. Perhaps that also indicates a deeper discoverability issue, but it certainly can be helped by fixing this.

#10 @karmatosed
2 months ago

  • Milestone changed from Awaiting Review to 5.0

#11 @ocean90
2 months ago

it is important we don't assume everyone knows how to change the default category, they simply do not. Perhaps that also indicates a deeper discoverability issue

So maybe we should fix this instead? Unchecking the default category sounds dangerous since it's not always "Uncategorized". It's a random category because of the weird concept that a post needs at least one category.

Note: See TracTickets for help on using tickets.