WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#36245 closed defect (bug) (duplicate)

wp-admin should be disallowed as a post slug

Reported by: wp_harish Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4.2
Component: Permalinks Keywords:
Focuses: Cc:

Description

My wordpress URL structure as follows,

http://localhost/wordpress/%postname%/

I create post with title wp admin
It generates post url as http://localhost/wordpress/wp-admin

Obviously its going to admin login page when i want to see content.. :)

Change History (3)

#1 @swissspidy
6 years ago

  • Summary changed from Wordpress redirect issue to wp-admin should be disallowed as a post slug

#2 @Clorith
6 years ago

Should probably also prevent the use of wp-content and wp-includes.

If we're blocking one we might as well block all 3 because it's a given that someone will try to use them.

#3 @swissspidy
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23478.

Note: See TracTickets for help on using tickets.