WordPress.org

Make WordPress Core

Opened 4 years ago

Last modified 2 years ago

#36258 reopened defect (bug)

BuddyPress Admin Toolbar becomes blank for non-logged users when loading site on a device with a screen smaller than 1024x768

Reported by: Valery Kondakoff Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 4.4.2
Component: Toolbar Keywords:
Focuses: ui Cc:

Description

BuddyPress Admin Toolbar becomes blank for non-logged users when loading site on a device with a screen smaller than 1024x768

Reproducible on Wordpress 4.5-beta3-37000, BuddyPress 2.5.1
Reproducible on WP 4.4.2 as well.

Attachments (2)

Screen Shot 2016-03-16 at 6.20.20.png (232.8 KB) - added by Valery Kondakoff 4 years ago.
Screen Shot 2016-03-16 at 6.20.04.png (261.5 KB) - added by Valery Kondakoff 4 years ago.

Download all attachments as: .zip

Change History (6)

#1 @swissspidy
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hey there,

Thanks for creating this ticket and welcome to WordPress Trac.

That sounds like a bug related to BuddyPress or perhaps the specific theme you're using. Because of that, I recommend you to check out the BuddyPress support forums to get help with this issue.

#2 @Valery Kondakoff
4 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Hello!

Sorry for inconvenience, but this bug is reproducible in any theme (at least in the three latest default themes: twenty fourteen, twenty fifteen and twenty sixteen).

I'm pretty sure this issue is not directly related to BuddyPress, as Admin Toolbar appears when BuddyPress is not installed at all (the only thing related to BuddyPress is the setting: "Show Admin Toolbar to not logged users").

Please, can you look at this issue once again? This bug is here for a long time. Here is one workaround that I have found to (partially) fix the issue: adding this snippet ('#wp-toolbar > ul > li {display:block;}' to custom CSS: the WP and search icons are still missed on small screens, but other buttons are available.

#3 @SergeyBiryukov
4 years ago

  • Component changed from General to Toolbar
  • Milestone set to Awaiting Review

#4 @SergeyBiryukov
2 years ago

Related: #meta723, #meta2376.

If this is still relevant, https://plugins.trac.wordpress.org/changeset/1588089 is an example of styles that should be added for Toolbar on mobile, either in BuddyPress or in WordPress core.

Note: See TracTickets for help on using tickets.