WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#36277 closed defect (bug) (invalid)

4.4.2 using constructor method for WP_Widget deprecated since 4.3.0

Reported by: jcrasco Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4.2
Component: Editor Keywords:
Focuses: Cc:

Description

Hi,
We are running 4.4.2 and recently upgraded Yoast Premium to 3.2.1. I have contacted Yoast with this same information...the debugger info is attached. WP was not displaying pages, meaning we cannot work on our site (www.valence.com). Our IT guy deactivated Yoast, which stopped the display problem, but apparently the issue is with WP.
Hope the debugger info is helpful.

Change History (1)

#1 @dd32
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

The errors you're seeing are not caused by WordPress, rather it's caused by a plugin you're running and theme.

You'll need to update the Yoast SEO premium plugin, or contact them to file a bug report. The notices generated by the theme are only deprecated warnings, which you don't really need to worry about.

For the reference of others, the errors within the originally attached file were:

Notice: register_sidebar was called incorrectly. No id was set in the
arguments array for the "Why Valence" sidebar. Defaulting to
"sidebar-5". Manually set the id to "sidebar-5" to silence this notice
and keep existing sidebar content. Please see Debugging in WordPress for
more information. (This message was added in version 4.2.0.) in
/srv/www/htdocs/wp-includes/functions.php on line 3792

Notice: The called constructor method for WP_Widget is deprecated since version 4.3.0! Use __construct() instead. in /srv/www/htdocs/wp-includes/functions.php on line 3624

Fatal error: Cannot instantiate abstract class WPSEO_Redirect_Manager in /srv/www/htdocs/wp-content/plugins/wordpress-seo-premium/premium/classes/class-post-slug-watcher.php on line 48

This Trac is for reporting bugs within WordPress itself, and not plugins, as such I'm marking this as invalid.

Note: See TracTickets for help on using tickets.