WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#36307 closed defect (bug) (duplicate)

WP 4.4.2 + PHP 7.x (rss.php)

Reported by: frymi Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:
PR Number:

Description

./⁠wp-⁠includes/⁠rss.php (change row 117)

php5: list($ns, $el) = split( ':', $element, 2);
php7: list($ns, $el) = preg_split( ':', $element, 2);

Attachments (1)

36307.v2.patch (1009 bytes) - added by achbed 4 years ago.
Fix to remove last instances of split()

Download all attachments as: .zip

Change History (4)

#1 in reply to: ↑ description @achbed
4 years ago

Replying to frymi:

./⁠wp-⁠includes/⁠rss.php (change row 117)

See also:
./wp-includes/atomlib.php line 316

Since this split does not need regex, I recommend using explode() instead. Patch attached.

@achbed
4 years ago

Fix to remove last instances of split()

This ticket was mentioned in Slack in #core by achbed. View the logs.


4 years ago

#3 @ocean90
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 4.4.2 deleted

Duplicate of #20673.

(Same applies to atomlib.php.)

Note: See TracTickets for help on using tickets.